Re: xspec module

From: Marc Audard <audard_at_email.domain.hidden>
Date: Fri, 07 Dec 2001 14:46:50 +0100
Dear John,


John Houck wrote:
> I suspect that this is a system-dependent problem associated
> with linking a C program (isis) with Fortran libraries (xspec).
> Also, what operating system and C compiler are you using to
> build isis? uname -a can be used to find the operating system
> information:
> 

Solaris 2.7

SunOS orion 5.7 Generic_106541-12 sun4u sparc SUNW,Ultra-5_10

> The compilers usually have a command-line option that gives
> the version:


I fear that the incompatibility arises from the use of the CC compiler.
For ISIS and S-LANG I used gcc 2.95.2, while for LHEASOFT/XSPEC I had to
use the Solaris cc.

I have recompiled isis and the xspec module with Solaris cc (S-Lang still gcc)
and indeed now it works fine!

--> problem resolved. However a note should be given saying that the user
should compile ISIS/module with the same compiler as LHEASOFT, especially for
Solaris users that need to use the Solaris cc.


Regards,

		Marc
----
You received this message because you are
subscribed to the isis-users list.
To unsubscribe, send a message to
isis-users-request_at_email.domain.hiddenwith the first line of the message as:
unsubscribe
Received on Fri Dec 07 2001 - 08:47:08 EST

This archive was generated by hypermail 2.2.0 : Thu Mar 15 2007 - 08:45:50 EDT